DHL eCommerce Americas API Incident notification - Label API

Major incident Label API
11-03-2024 01:36 EST · 1 hour, 46 minutes

Updates

Resolved

The issue has been resolved. We take all measures to minimize customer impact while ensuring we maintain great customer solutions. Thanks for your patience.

November 3, 2024 · 03:22 EST
Issue

We are actively engaged in investigating an issue with a DHL eCommerce Americas API. An update will be provided when we have more information or when the issue is resolved.

November 3, 2024 · 01:36 EST

← Back