DHL eCommerce Americas API Incident notification - Tracking API

Major incident Tracking API
04-06-2025 04:34 EDT · 1 hour

Updates

Resolved

The issue has been resolved. We take all measures to minimize customer impact while ensuring we maintain great customer solutions. Thanks for your patience.

April 6, 2025 · 05:35 EDT
Issue

We are actively engaged in investigating an issue with a DHL eCommerce Americas API. An update will be provided when we have more information or when the issue is resolved.

April 6, 2025 · 04:34 EDT

← Back