DHL eCommerce Americas API Incident notification - Manifest API

Major incident Manifest API
04-21-2025 20:34 EDT · 47 minutes

Updates

Resolved

The issue has been resolved. We take all measures to minimize customer impact while ensuring we maintain great customer solutions. Thanks for your patience.

April 21, 2025 · 21:21 EDT
Issue

We are actively engaged in investigating an issue with a DHL eCommerce Americas API. An update will be provided when we have more information or when the issue is resolved.

April 21, 2025 · 20:34 EDT

← Back